handleidingen:netwerk:openwrt-freedom-ftth

Deze pagina is ook beschikbaar in het Engels.


Dit artikel beschrijft hoe ik FttH heb ingesteld voor Freedom.nl, terwijl ik gebruik maak van mijn eigen NTU en router. Ik heb deze setup thuis. Ik gebruik alleen het internet; ik kijk geen “ouderwetse” TV, maar ik heb een los Canal Digitaal-abonnement, zodat ik geen met blobs overladen settopboxen nodig heb. Dus mijn netwerk is relatief eenvoudig.

Ik heb ervoor gekozen om Freedom's Fritz!Box niet te ontvangen, omdat ik niet de intentie had die ooit te gebruiken. Die dingen bieden veel te veel functionaliteit naar mijn zin, zonder enige broncode vrij te geven. Alles dat ik wil is een domme NTU die zo min mogelijk doet. Het moet de glasvezel omzetten naar een ethernet-trunk, en verder niets.

Gelukkig is Freedom één van de weinige ISP's in de wereld die haar klanten geen verplichte apparaten opdringt. Sterker nog, ze laten je tijdens het bestelproces kiezen of je hun hardware wilt gebruiken, en geven je zelfs een kleine korting als je dat niet wilt. Dit is absoluut geweldige service. Ik wacht al op iets als dit voor zo lang ik leef.

Ik ben een uitgesproken voorstander van modem- en routervrijheid, dus ik ben het niet eens met de huidige situatie dat bijna alle ISP's hun klanten modemrouters opdringen. De Duitsers noemen dit Routerzwang. (Natuurlijk hebben zij er een woord voor…)

Dus in plaats van een Fritz!Box te huren, heb ik een ZTE ZXHN F3100 gigabit media converter / NTU gekocht. Hij draait nauwelijks enige software, aangezien de mediaconversie voornamelijk in hardware wordt gedaan.

Al het echte werk wordt gedaan door mijn vertrouwde TP-Link TL-WDR4300 die OpenWrt draait. Omdat dit apparaat een Atheros AR9344-chipset heeft, heeft hij geen blobs nodig om te werken.



De OpenWrt-router zal als het daadwerkelijke endpoint in het IP-netwerk dienen. Alle pakketten zullen onveranderd door het modem gaan.

Dit betekent dat de router zal moeten werken als VLAN-switch, PPPoE-client, NAT-gateway, DHCPv4- en DHCPv6-server, en een IPv6 RA-server voor SLAAC.

Ik werk het liefst met SSH en vi om OpenWrt te configureren, maar ik zal ook proberen om de GUI te documenteren.

VLAN's instellen

Als eerste moeten we de switch configureren. Verander in /etc/config/network het onderste gedeelte config switch_vlan als volgt:

# Dit is het LAN-VLAN, dat de vier gele LAN-poorten verbindt
config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0t 2 3 4 5'
 
# Dit is het getagte WAN-VLAN om het internet te benaderen
config switch_vlan
	option device 'switch0'
	option vlan '6'
	option ports '0t 1t'


Als je liever LuCI gebruikt, stel je Network > Switch als volgt in:

Klik op Save, maar pas de configuratie nog niet toe.

De WAN-interfaces instellen

Hogerop in /etc/config/network verander je de lan, wan- en wan6- interfaces als volgt.

Voor OpenWrt 19.07:

# Dit zet de MTU van de ethernet-adapter op 1508, zodat we MTU 1500 in de PPPoE-tunnel kunnen gebruiken
config device
	option name 'eth0'
	option mtu '1508'
 
# Zet de MTU van LAN op 1500
config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option mtu '1500'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
 
# Dit is het getagte WAN-VLAN om het internet te benaderen
# Zet de MTU op 1508, omdat PPPoE 8 bytes overhead heeft
config interface 'wan'
	option ifname 'eth0.6'
	option mtu '1508'
	option proto 'pppoe'
	option username 'fake@freedom.nl'
	option password '1234'
	# Niet noodzakelijk, maar ik heb graag extra logging
	option pppd_options 'debug'

Let op dat je de wan6-interface volledig verwijdert, aangezien die niet nodig is. De PPPoE-tunnel zal automatisch een virtuele IPv6 WAN-interface aanmaken.

Voor OpenWrt 21.02:

# Dit zet de MTU van de ethernet-adapter op 1508, zodat we MTU 1500 in de PPPoE-tunnel kunnen gebruiken
config device
	option name 'eth0'
	option mtu '1508'
 
# Zet de MTU van LAN op 1500
config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0.1'
 
config interface 'lan'
	option device 'br-lan'
	option mtu '1500'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
 
# Dit is het getagte WAN-VLAN om het internet te benaderen
# Zet de MTU op 1508, omdat PPPoE 8 bytes overhead heeft
config interface 'wan'
	option device 'eth0.6'
	option mtu '1508'
	option proto 'pppoe'
	option username 'fake@freedom.nl'
	option password '1234'
	# Niet noodzakelijk, maar ik heb graag extra logging
	option pppd_options 'debug'

Let op dat je de wan6-interface volledig verwijdert, aangezien die niet nodig is. De PPPoE-tunnel zal automatisch een virtuele IPv6 WAN-interface aanmaken.

Als je liever LuCI gebruikt, stel je Network > Interfaces > WAN als volgt in:

Let op dat je de WAN6-interface volledig verwijdert, aangezien die niet nodig is. De PPPoE-tunnel zal automatisch een virtuele IPv6 WAN-interface aanmaken.

Klik op Save, maar pas de configuratie nog niet toe.

De instellingen toepassen

Als je de command line gebruikt, herstart je de netwerkservice:

service network restart


Als je liever LuCI gebruikt, klik je op Save & Apply.

Als je alles correct hebt gevolgd, zou je nu een /32 IPv4-adres en een /48 IPv6-prefix op je WAN-interfaces moeten ontvangen.

Verbonden LAN-clients zouden een DHCPv4-lease, een DHCPv6-lease en een SLAAC-adres moeten ontvangen.




  • handleidingen/netwerk/openwrt-freedom-ftth.txt
  • Last modified: 2021/06/10 14:38
  • by Kevin Keijzer